Review: Banana Pi Router (BPI-R1)

Achtung! Dieser Artikel ist älter als ein Jahr. Der Inhalt ist möglicherweise nicht mehr aktuell!

Eigentlich sollte das eine Review zu Design, Leistung und die neuen Möglichkeiten werden. Leider habe ich nichts testen können, da ich keine Netzwerkpakete versenden kann.

Aber von Anfang an …

Warum ein Bastel-Router?

Mein Raspberry Pi übernimmt ein paar wichtige Netzwerkdienste in meinem Heim-Netzwerk. Allerdings sind mir die 700 MHz zu langsam. Das ganze System fühlt sich träge an.

IMG_20141209_203019

Eigentlich wollte ich mir ein leistungsstärkeres Board zulegen. Beim herumschauen und vergleichen bin ich auf das Banana Pi Router Board gestoßen und war schon begeistert. Bis jetzt standen alle meine Netzwerkgeräte bei mir auf den Tisch: Switch, NAS, Router, Kamera und das Banana Pi. Ein LAN-Kabel geht noch quer durch die Wohnung und endet beim Fernseher.

Erhofft hatte ich mir, dass ich das LAN-Kabel zum Fernseher als Brücke zwischen zwei Switche: Meinen Desktop Switch und dem Banana Pi Router. NAS und Fernseher werden dann an das Router Board angeschlossen. Zudem übernimmt das Board die Aufgaben des Raspberry Pi.

Tja … In der Zwischenzeit habe ich mir einen neuen 8-Port-Switch gekauft. Den selben, den ich schon hatte. Warum es zwei verschiedenen Verpackungen gibt bleibt mir zumindest ein Rätsel :-)

IMG_20141205_162815

Aber hier geht es nicht um meinen Switch, sondern um das Board.

Probleme: Kein Netzwerk

Als Image habe ich zuerst das Bananian Image ausprobiert (Version vom 04.12.2014 und die davor). Beide Images haben auch ohne Probleme gebootet.

Während des bootens sind sämtliche DHCP Anfragen im Sande verlaufen. In der Syslog des Raspberry Pi (auf dem der DHCP läuft) habe ich keine Requests gesehen. Nach 5 Versuchen bootet das Board ohne Netzwerkconfig.

Danach habe ich über /etc/network/interfaces einfach statisch eine IP-Adresse zugeteilt und neu gestartet.

Leider ohne Erfolg. Mehrmals habe ich die Config gecheckt: „Netzmaske – stimmt!“, „IP-Adresse frei – check!“, „Gateway – stimmt!“.

Dann habe ich versucht diverse Geräte in meinem Netz zu pingen – alles ohne Erfolg. Localhost ging aber. Die Syslog, der Kernellog und dmesg blieben leer – keine Fehler!

Verzweifelt habe ich dann versucht mit dem original Debian 7 armhf Image das Netzwerk zum laufen zu bekommen. Leider auch ohne Erfolg. Zuerst dachte ich, dass das Board einen Defekt hat. Aber dann würde die Netzwerkkarte gar nicht erkannt werden.

Gott sei Dank bin ich aber nicht der einzige mit dem Problem! Im Golem Forum hat ein User ebenfalls das selbe Problem wie ich.

Auswahl_006

Aktuell warte ich auf einen fix für das. Wie Golem die Tests gemacht hat ist mir immer noch ein Rätsel, denn mit OpenWRT hab ich die Netzwerkkarte immer noch nicht ansprechen können.

Ernüchterung und Enttäuschung

Nach dem Kauf ist mir aber einiges klar geworden. Im Grunde genommen täuscht das „Router“ im Namen. Eigentlich ist es nur ein Banana Pi mit einem zusätzlichen „dummen“ 4-Port Gigabit Switch. Einzelne Ports können nicht angesprochen werden.

Erwartet habe ich eigentlich eth[0-4] vorzufinden, sodass man tatsächlich auch routen könnte. Eine einfache Firewall wäre so zum Beispiel ebenfalls möglich gewesen. Laut Golem wird das Switching aber direkt in Hardware gemacht. Es geht also nicht auf die CPU. Der Speed soll gut sein.

Vor dem Kauf also Augen auf! Ich bin jedoch enttäuscht und hoffe, dass bald ein richtiges Routing-Board auf den Markt kommt. Siehe folgenden Nachtrag :-)

Nachtrag 11.12.2014

Siehe auch:  https://www.bananian.org/hardware

Siehe auch: https://www.bananian.org/hardware

Mittlerweile bin ich auf Twitter von @tryvann angeschrieben worden. Laut seinem Profil Project Leader bei bananian Linux. Er hat mich darauf hingewiesen, dass das BPI-R1 gar nicht unterstützt wird :-)

In einem vorherigen Tweet hat er gesagt, dass im nächsten Release der Treiber dafür aber inbegriffen ist. Leider steht aktuell noch kein Releasedatum.

An dieser Stelle will ich mich für den letzten Satz im Hauptteil entschuldigen. Geschrieben habe ich diesen nach vier Stunden basteln und war genervt :-( Hier habe ich einen Fehler gemacht – Wenn man eine „falsche“ Software nimmt kann man das Ergebnis nicht schlecht reden.

Nun, das erklärt warum auch Debian 7 armhf nicht funktioniert hat. Aber das OpenWRT Image, dass angeblich von Golem verwendet wurde hat bei mir auch nicht funktioniert.


Du hast einen Kommentar, einen Wunsch oder eine Verbeserung? Schreib mir doch eine E-Mail! Die Infos dazu stehen hier.

🖇️ = Link zu anderer Webseite
🔐 = Webseite nutzt HTTPS (verschlüsselter Transportweg)
Zurück